distal-attribute
distal-attribute
distal-attribute
distal-attribute

Importing CSV files

Daniele68 posted 11 years ago in Import/Export
I'm somewhat new to SQL. I had a previous version in which I could select Import, choose CSV then It would allow me to map the fields from my CSV file to the Sql database. first, I don't see that option in this program. Second, I can't seem to import anything at all. What am I doing wrong?
ansgar posted 11 years ago
Simply chose "Import/Export" -> "Import Textfile" and try.
Daniele68 posted 11 years ago
I've tried the import text file. It doesn't work. Does it matter that my field names in the CSV file are different from the database field names? This is why I was hoping I could map the fields.
ansgar posted 11 years ago
What means "it doesnt work" ? Where? What exactly happens?

With "field names in your CSV-file" I guess you mean the cells in the first line of the file. It doesn't matter how they are named, but in fact it does matter how many columns the CSV-file has. You have to manually sort and (un-)check the columns in the listbox to reflect the structure of your CSV-file. There is no automatism yet which does this job for you.

Maybe this is a future thing for HeidiSQL. As I overthink that, I find that's a cool feature which should be posted to http://rfe.heidisql.com/ .
theone posted 11 years ago
I'm kind of wrestling with the same issue except that all i need to know is what do I put in the "Lines:" "terminated by" to let it know to start the next line? I'm assuming I would want to have a return here? What do I enter in the box that represents a "return"?
theone posted 11 years ago
Okay i figured out how to get the import to happen using a comma delimited file but how do I handle a file that has text in fields that also have commas in the sentence? I'm using Excel and i'm sure there is a way to tell it to use something other than a comma for field seperation? Any helpful clues?
siMKin posted 11 years ago
excel probably gives a really good example when you export to (save as) CSV ... :roll:

anyways, you'll have to enclose the values of a field with a special symbol .. for example the " (quote). and whenever this symbol appears as part of the value, you have to escape it with another symbol .. for example the \

"this is \"an\" example", "and this another one"


and i'm not sure if you had figured this out, be a return can be either \r\n, \r or \n, depending on which platform you are (window, mac, linux)
theone posted 11 years ago
Thanks for your little lesson in db 101. I'm just getting this stuff figured out and this program has been very helpful with the process. :D
theone posted 11 years ago
Did some looking into Excel to figure out how to use something other than a comma for field ending and could not find anything. But I discovered Open Office in the process which gives you the option select what character you want to use.
siMKin posted 11 years ago
excel automatically compensates for commas by enclosing them between quotes, when saving it as a CSV file

But, don't let stop you from Calc (Open Office)! It's much better the MS Office :)
mariela21180 posted 1 month ago

Guys, I find a great tool to import CSV to Heidi and I wanted to share it with you.

On this page I get to convert an .csv file into an SQL command to import: convertcsv.com / csv-to-sql.htm And then I've copied the result text to Heidi and works perfectly

Andrew posted 3 weeks ago

I've recently started using Heidi after a recommendation. My only problem is up until monday everything was fine. But since I have not been able to import a CSV file. I keep getting a connection error however there is no problem with the connection as I can run queries perfectly fine.

I can even run some of the import as insert statements. Worked fine for 40000+ records. However I need to get nearly 1.5million records into the table and doing it as inserts would take far too long.

BubikolRamios posted 2 weeks ago

It probably takes connection and then that connection dies on server as it's life time is probably limited on server or elsewhere.

That is, while it imports huge csv. Try to import to local server, if not already ...

Please login to leave a reply, or register at first.