Ads were blocked by your webbrowser.

This is not a problem, but keep in mind that developing HeidiSQL, user support and hosting takes time and money.

You may want to send a donation instead.

Crash when trying to read a table on SQL Server

tonymarston's profile image tonymarston posted 1 year ago in General

I had logged onto my SQL Server database, selected a table, then hit the "data" tab to se its contents when it just crashed. Attached is the dump.

1 attachment(s):
nickles's profile image nickles posted 7 months ago

Same issue here. The table contains GUID columns. Tried to reduce the columns, rows, and result is below (bugreport, table CREATE and data (one row!) in attachments.

This bug has been nagging me since about 9.4. Right now I have to resort to SQL Server Management Studio which is quite a nuisance...

I'd really appreciate if you could look into this.

2 attachment(s):
ansgar's profile image ansgar posted 7 months ago

@tonymarston: please update to HeidiSQL 10.1, you are running an old version.

@nickles: your issue is different. Probably that's issue #496. You could have a look there and compare the reproduction recipe.



Ads were blocked by your webbrowser.

This is not a problem, but keep in mind that developing HeidiSQL, user support and hosting takes time and money.

You may want to send a donation instead.
nickles's profile image nickles posted 7 months ago

@ansgar

Don‘t see any fix in #496. It‘s very certainly related to one of the column types - but how would I remedy that? I cannot change any of these... Please consider looking into the the data I sent in; you should be able to reproduce the error.

tonymarston's profile image tonymarston posted 7 months ago

I am running version 10.1.0.5479 and still hitting the same error. See attached bug report.

1 attachment(s):
nickles's profile image nickles posted 7 months ago

Status: Still throwing in 10.1.0.5481.

nickles's profile image nickles posted 6 months ago

Status: Still throwing in 10.1.0.5508.

nickles's profile image nickles posted 5 months ago

Status: Still throwing in 10.1.0.5545.

tonymarston's profile image tonymarston posted 5 months ago

What do you mean by 'part'? The column is defined as decimal(38,0), so what is missing?

tonymarston's profile image tonymarston posted 4 months ago

What has a fault with an Epson printer got to do with this issue?



Ads were blocked by your webbrowser.

This is not a problem, but keep in mind that developing HeidiSQL, user support and hosting takes time and money.

You may want to send a donation instead.
ansgar's profile image ansgar posted 4 months ago

This was spam. I'm going to delete merry007.

tonymarston's profile image tonymarston posted 3 months ago

Status: Still throwing in 10.2.0.5610.

ansgar's profile image ansgar posted 2 months ago

The crash report looks like in issue #423. I just set that to the roadmap for the next release. You could star that issue and probably check when I committed a solution.

Please login to leave a reply, or register at first.